Status

Delays in identity verification

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted Nov 11, 2021 - 03:13 UTC

Investigating

We are currently investigating this issue.
Posted Nov 03, 2021 - 02:58 UTC
This incident affected: Identity Verification (PhotoID verification, Identity Screening).