RESOLVED: BitPay Card Loads Not Applied
Incident Report for BitPay Inc
Resolved
Our BitPay Mastercard partner was experiencing a temporary outage from approximately 6PM ET to 10 ET. All BitPay Card loads from this time have been applied.
Posted Feb 17, 2022 - 23:00 UTC