Unable to create invoices
Incident Report for BitPay Inc
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 19:06 UTC
Investigating
We have been notified that some customers are unable to create invoices on the BitPay platform. We are currently investigating the issue.
Posted Mar 11, 2024 - 16:51 UTC
This incident affected: Payments (API Invoice, API Invoice - BTC, API Invoice - BCH, API Invoice - ETH, API Invoice - GUSD, API Invoice - BUSD, API Invoice - USDC, API Invoice - PAX, API Invoice - XRP, API Invoice - DOGE).