Status

Polygon Network Issues on Invoice

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 21:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 20, 2025 - 15:22 UTC

Investigating

We are investigating issues with payments on the Polygon network. Until we have resolved the issue we are disabling payments via Polygon.
Posted Feb 20, 2025 - 02:55 UTC
This incident affected: Payments (API Invoice - MATIC).