Intermittent errors for BitPay Card loads
Incident Report for BitPay Inc
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 17:29 UTC
Investigating
We're aware of this issue and currently investigating the cause of it. We will post additional updates as soon as possible.
Posted Nov 26, 2021 - 21:07 UTC
This incident affected: Bitpay Card (MasterCard (USA)).