BTC Mainnet Synching Slowly
Incident Report for BitPay Inc
Resolved
This incident has been resolved.
Posted May 10, 2023 - 19:03 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 10, 2023 - 19:03 UTC
Investigating
We are experiencing slow updates to BTC balances in the BitPay Wallet app. Our appropriate technical teams are aware of the issue and are investigating.

This does not affect the sending of funds.
Posted May 10, 2023 - 15:23 UTC
This incident affected: Wallet (BTC).