Delayed Confirmations on ETH, MATIC, and ERC-20 Tokens
Incident Report for BitPay Inc
Resolved
This incident has been resolved.
Posted Nov 13, 2022 - 01:52 UTC
Investigating
We are currently investigating an issue causing delayed confirmations on ETH, MATIC, and ERC-20 Tokens.

We have temporarily disabled payment via these currencies while we work to resolve this issue.
Posted Nov 12, 2022 - 23:11 UTC
This incident affected: Wallet (ETH & ERC20) and Payments (API Invoice - ETH, API Invoice - GUSD, API Invoice - BUSD, API Invoice - USDC).