Status

bitpay.com/card not displaying correctly

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted Apr 22, 2021 - 19:41 UTC

Identified

We are working on fixing an issue which is causing bitpay.com/card to not load properly. Card sign-ups are unaffected in the BitPay App. The cardholder dashboard is also unaffected.
Posted Apr 22, 2021 - 14:41 UTC
This incident affected: Bitpay Card (MasterCard (USA)).