Status

Delays in identity verification

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted Oct 20, 2020 - 15:35 UTC

Identified

Our identity verification service provider is currently experiencing an issue which is causing ID and selfie verification to be delayed. We will provide an update shortly.
Posted Oct 20, 2020 - 12:27 UTC
This incident affected: Identity Verification (PhotoID verification, Identity Screening).