Status

Card Signups unavailable

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted Apr 13, 2021 - 00:20 UTC

Update

Issue resolved
Posted Apr 13, 2021 - 00:19 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 12, 2021 - 21:02 UTC
This incident affected: Bitpay Card (MasterCard (USA)).