Instability with BitPay.com
Incident Report for BitPay Inc
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 21:13 UTC
Monitoring
Stability has been restored and our development teams are monitoring.
Posted Nov 25, 2022 - 19:27 UTC
Investigating
We are currently experiencing instability with BitPay.com and associated applications. The appropriate teams are investigating.
Posted Nov 25, 2022 - 18:55 UTC
This incident affected: Payments (API Invoice), Wallet (Bitcore Wallet Service), and Bitpay.com (Bitpay HealthCheck).