BitPay App Experiencing Issues
Incident Report for BitPay Inc
Resolved
This incident has been resolved.
Posted Nov 10, 2022 - 22:30 UTC
Investigating
We have reports that some users are receiving a gray screen when attempting to log into the BitPay App.

This issue is currently being investigated.
Posted Nov 10, 2022 - 21:31 UTC
This incident affected: Wallet (Bitcore Wallet Service) and Bitpay Card (MasterCard (USA)).