Status

ETH and USDC on the BASE network are currently disabled.

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted May 30, 2025 - 14:27 UTC

Investigating

Due to an issue we were experiencing, we've disabled ETH and USDC on the BASE network. The appropriate teams are looking into when we can re-enable these currencies.

All other currencies remain operational.
Posted May 28, 2025 - 16:55 UTC
This incident affected: Payments (API Invoice).