Status

Issues with ID verification

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted Jun 03, 2021 - 13:33 UTC

Investigating

Some identity verification applications will be delayed - we are currently investigating this issue.
Posted May 05, 2021 - 14:52 UTC
This incident affected: Identity Verification (PhotoID verification, Identity Screening).