Status

Intermittent Errors

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted Apr 06, 2025 - 02:40 UTC

Investigating

We are experiencing intermittent errors on BitPay.com.

Our team is investigating, but at this time, it appears the majority of users are still able to transact.
Posted Apr 05, 2025 - 21:52 UTC
This incident affected: Payments (API Invoice).