Status

Intermittent Inaccessibility

Incident Report for BitPay Inc

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 18:22 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 29, 2026 - 18:21 UTC

Update

This issue has been resolved
Posted Apr 29, 2026 - 17:43 UTC

Identified

Some users are experiencing difficulties connecting to BitPay.com.

We have identified the root cause and are working on deploying a fix.
Posted Apr 29, 2026 - 17:15 UTC
This incident affected: Bitpay.com (Bitpay HealthCheck, Bitpay HealthCheck (Sandbox)).